problème avec goto

Discussion sur l'enseignement de l'algorithmique avec Xcas au lycee
KALCH
Messages : 2
Inscription : jeu. juil. 26, 2012 5:44 pm

problème avec goto

Message par KALCH » jeu. juil. 26, 2012 6:36 pm

j'ai un petit souci avec les fonction label et goto, même l'algorithme proposé dans l'aide ne fonctionne pas:

f(x):={
label ligne;
x:=x+2;
if(x<10)
goto ligne;
return(x);}

f(11) retourne 13 normal
f(7) devrait donner 11 mais le programme ne s'arrête pas
je me trompe????
on peut se passer de goto mais j'en ai besoin ailleurs

parisse
Messages : 5084
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: problème avec goto

Message par parisse » ven. juil. 27, 2012 6:42 am

Je viens de tester avec la dernière version (instable) et ca semble fonctionner, quelle version utilisez-vous?

KALCH
Messages : 2
Inscription : jeu. juil. 26, 2012 5:44 pm

Re: problème avec goto

Message par KALCH » ven. juil. 27, 2012 6:58 am

parisse a écrit :Je viens de tester avec la dernière version (instable) et ca semble fonctionner, quelle version utilisez-vous?

j'ignore la version mais je l'ai téléchargée il y a au moins 2 ans, est-il avantageux de disposer de la dernière version? Merci

parisse
Messages : 5084
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: problème avec goto

Message par parisse » ven. juil. 27, 2012 9:11 am

Oui, comme xcas est encore relativement jeune, il est judicieux de mettre à jour de temps en temps (par exemple une fois par an) pour bénéficier des corrections de bugs et améliorations.

Répondre