Latex output problems

Messages in english

Modérateur : xcasadmin

XcasEngGuy
Messages : 68
Inscription : mer. janv. 13, 2010 3:20 pm

Latex output problems

Message par XcasEngGuy » dim. juil. 07, 2013 8:42 pm

I noticed you included a "dot" between variables that are multiplied together in the latex output. This helps a problem I have been having. However, the "dot" only seems to be included between the first two variables encountered in a given equation.

Here is an example
Image

I hope that worked.

Could you fix it so all products are identified with a "dot" to eliminate confusion in variable names? Or make it an option? For example, "m*a*s*s" would look like "mass" right now. I am using xcas 1.0.0-4 (c) 2000-8.

Thanks,
Matt

XcasEngGuy
Messages : 68
Inscription : mer. janv. 13, 2010 3:20 pm

Re: Latex output problems

Message par XcasEngGuy » mar. oct. 20, 2020 3:07 pm

Unfortunately the feature I described in this post, which you added and helps me a lot, seems to have been lost in the latest update.

Could you fix it so all products are identified with a "dot" to eliminate confusion in variable names? Or make it an option? For example, "m*a*s*s" would look like "mass" right now.

Thanks for all your timely help,
Matt

parisse
Messages : 5112
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: Latex output problems

Message par parisse » mar. oct. 20, 2020 4:23 pm

This is perhaps a consequence of the new code handling latex output in markup.cc. Maybe I should add a command to enable/disable old code, something like latex("legacy",1) or latex("legacy",0)

XcasEngGuy
Messages : 68
Inscription : mer. janv. 13, 2010 3:20 pm

Re: Latex output problems

Message par XcasEngGuy » mar. oct. 20, 2020 5:18 pm

I am very willing to try that.
I think there were errors in the legacy code when outputting calculations with units. I was working with that before.
I would like to have the flexability to choose which code to use. I think I can make that work for what I need.

Thanks,
Matt

Répondre