xcasen.html

Messages in english

Modérateur : xcasadmin

belanger
Messages : 46
Inscription : jeu. juil. 27, 2017 3:26 pm

xcasen.html

Message par belanger » mer. déc. 11, 2019 5:12 pm

Hi All,

When running Xcas in Firefox by going to
https://www-fourier.ujf-grenoble.fr/~pa ... casen.html
it works fine. But when I try to install it locally by downloading
http://www-fourier.univ-grenoble-alpes. ... ashtml.zip
unzipping it and opening xcasen.html (even after clearing the cache),
it won't work for me.
On Android, I get the message at the end of the page
Downloading and preparing (may take 1 or 2 minutes the first time)
which doesn't go away. On Linux, I get the message

on the web, we need the wasm binary to be preloaded and set on Module['wasmBinary']. emcc.py will do that for you when generating HTML (but not JS)
abort("on the web, we need the wasm binary to be preloaded and set on Module['wasmBinary']. emcc.py will do that for you when generating HTML (but not JS)") at jsStackTrace@file:///home/belanger/Downloads/xcasoffline/giacwasm.js:1:13079
stackTrace@file:///home/belanger/Downloads/xcasoffline/giacwasm.js:1:13250
abort@file:///home/belanger/Downloads/xcasoffline/giacwasm.js:1:392011
getBinary@file:///home/belanger/Downloads/xcasoffline/giacwasm.js:1:22372
getBinaryPromise/<@file:///home/belanger/Downloads/xcasoffline/giacwasm.js:1:22731

Preparing...

(Same thing if I open xcasfr.html or xcasenwasm.html).
This may well be that I'm doing something wrong, but I was wondering
if anyone else has this problem.

Jay

parisse
Messages : 5081
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: xcasen.html

Message par parisse » mer. déc. 11, 2019 8:01 pm

Try to disable wasm in the settings. If you still want to run with wasm enabled with Firefox, try something like https://stackoverflow.com/questions/488 ... g-a-plugin or install a cross domain plugin.
For Android I don't know, wasm should be automatically disabled...

belanger
Messages : 46
Inscription : jeu. juil. 27, 2017 3:26 pm

Re: xcasen.html

Message par belanger » mer. déc. 11, 2019 11:13 pm

Fantastic, thanks!
It worked for Firefox in both in Linux (Ubuntu) and Android. In both cases, I just went to
about:config
and searched for wasm. It was originally enabled in both Ubuntu and Android.

Thanks,
Jay

Répondre