csolve(x^2=-1,'=') crashes and closes (installation version)

Messages in english

Modérateur : xcasadmin

compsystems
Messages : 539
Inscription : sam. févr. 04, 2017 11:34 pm
Localisation : Colombia
Contact :

csolve(x^2=-1,'=') crashes and closes (installation version)

Message par compsystems » mar. janv. 05, 2021 2:10 am

Hi, versión Xcas 1.6.0-39 (win64 bits installation version)

csolve(x^1=-1,'=') [enter] set[x=-1]
csolve(x^2=-1,'=') [enter] the app crashes and closes =(

The problem is with the GUI (xCAS on win64bits), not with the GIAC core, as in the online version it is fine.

An idea :idea: , look for third parties to develop a new GUI for GIAC.
I do not have the power to summon this, my position is that of a simple instructor of basic programming languages, or at least someone to check the current GUI and troubleshoot.
sorry if I have expressed myself wrong.

parisse
Messages : 5344
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: csolve(x^2=-1,'=') crashes and closes (installation version)

Message par parisse » mar. janv. 05, 2021 2:39 pm

Works here. I suggest that you try with the mingw version

compsystems
Messages : 539
Inscription : sam. févr. 04, 2017 11:34 pm
Localisation : Colombia
Contact :

Re: csolve(x^2=-1,'=') crashes and closes (installation version)

Message par compsystems » ven. janv. 15, 2021 4:25 pm

sorry, where do I find the mingw version of Xcas?

parisse
Messages : 5344
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: csolve(x^2=-1,'=') crashes and closes (installation version)

Message par parisse » ven. janv. 15, 2021 6:18 pm

It should be displayed with the latest xcaswininst.exe.

XcasEngGuy
Messages : 78
Inscription : mer. janv. 13, 2010 3:20 pm

Re: csolve(x^2=-1,'=') crashes and closes (installation version)

Message par XcasEngGuy » jeu. mai 20, 2021 5:20 pm

Works fine on my WIn10 64bit

compsystems
Messages : 539
Inscription : sam. févr. 04, 2017 11:34 pm
Localisation : Colombia
Contact :

Re: csolve(x^2=-1,'=') crashes and closes (installation version)

Message par compsystems » mar. mai 25, 2021 2:38 am

64 bits cygwin version ok

Répondre