linsolve with algebraic numbers and giacpy

jocaps
Messages : 118
Inscription : lun. avr. 17, 2017 4:32 pm

linsolve with algebraic numbers and giacpy

Message par jocaps » mar. juil. 17, 2018 10:23 pm

Hi,

I am having a rather unusual output from linsolve when trying to solve a system of linear equation over algebraic numbers. The system that I have is defined by a matrix and I want to solve the kernel of this matrix. The matrix is rather long (so it is not a good idea to put it in this forum) but I have provided a pastebin link to it: https://pastebin.com/ErJsDxGq

What i do is I defined this matrix as m in giacpy and then I do the following

Code : Tout sélectionner

b = [0]*9 #the answer vector should be 0
print linsolve(m,b) #see m in pastebin link
giacpy seems to solve things correctly for me. The final solution has 2 free variable and is

Code : Tout sélectionner

[-C_1,C_0,C_1,0,-3*C_0,-2*C_1,C_0,C_1,0,C_1]
but while finding this solution, giacpy outputs multiple lines of the following (this basically fills my screen!)
Unable to build a single algebraic extension for simplifying.
Trying rational simplification only. This might return a wrong answer if simplifying 0/0!
I don't get such behaviour in XCas. Any ideas? Thanks in advance!

Jose

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: linsolve with algebraic numbers and giacpy

Message par frederic han » mar. juil. 24, 2018 6:59 am

When I launch xcas from a terminal I can see the same message in the terminal. I guess it is sent by the giac library to the standard err output.

If I launch python with

Code : Tout sélectionner

python 2>/dev/null
I don't see this message in giacpy.

Répondre