bug d'interface avec plot3d

Bugs

Modérateur : xcasadmin

jan
Messages : 2
Inscription : sam. sept. 26, 2015 11:18 am

bug d'interface avec plot3d

Message par jan » sam. sept. 26, 2015 4:01 pm

Bonjour,
Quand je demande un graphe en 3d, il s'affiche, mais le reste de la fenêtre devient noir. J'arrive à faire ressortir certains éléments (par exemple la ligne de commande), mais jamais les menus. Pourtant les menus, même cachés, restent actifs : si l'on devine où ils sont, les sous-menus apparaissent.
Exemple :

Code : Tout sélectionner

plot3d(x^2+y^2,x,y)
Résultat ci-dessous. Ce bug se répète à chaque essai.
La deuxième image montre un dysfonctionnement pareil qui est arrivé une fois. (L'option affichage=vert+rempli n'a pas été prise en compte.)
Pour réparer, il faut relancer XCAS.
Configuration : Windows 10, xcas 1.2.0

Avez-vous une idée de ce qui se passe ?
Pièces jointes
xcas_bug_plot3d_menu.PNG
xcas_bug_plot3d_menu.PNG (33.16 Kio) Consulté 3092 fois
xcas_capt_bug_2.PNG
xcas_capt_bug_2.PNG (54.12 Kio) Consulté 3092 fois

parisse
Messages : 5082
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: bug d'interface avec plot3d

Message par parisse » dim. sept. 27, 2015 7:13 am

Ca semble etre une mauvaise prise en charge de opengl par la carte graphique, je n'ai helas pas de solutions dans xcas. Par contre, il est possible que la prise en charge de webgl soit meilleure, pouvez-vous essayer la meme commande dans
http://www-fourier.ujf-grenoble.fr/%7ep ... casfr.html

jan
Messages : 2
Inscription : sam. sept. 26, 2015 11:18 am

Re: bug d'interface avec plot3d

Message par jan » dim. sept. 27, 2015 11:20 am

parisse a écrit :Ca semble etre une mauvaise prise en charge de opengl par la carte graphique, je n'ai helas pas de solutions dans xcas. Par contre, il est possible que la prise en charge de webgl soit meilleure, pouvez-vous essayer la meme commande dans
http://www-fourier.ujf-grenoble.fr/%7ep ... casfr.html
Merci de votre réponse même si elle ne résout pas encore mon problème ; je poursuivrai mes recherches côté carte graphique et si je trouve une solution, je la présenterai sur ce forum.

parisse
Messages : 5082
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: bug d'interface avec plot3d

Message par parisse » dim. sept. 27, 2015 11:49 am

En fait, je pense que la lib graphique utilisee par xcas redefinit certaines couleurs, il est peut-etre possible de configurer le lancement de Xcas avec une compatibilite pour windows inferieur.

Répondre