"autosave" feature moves focus to the application

Bugs

Modérateur : xcasadmin

niccolo
Messages : 22
Inscription : dim. mars 02, 2014 2:13 pm

"autosave" feature moves focus to the application

Message par niccolo » dim. mai 26, 2019 3:24 pm

I'm using xcas 1.2.3 (of Ubuntu 18.04).

xcas has an autosave feature: every minute, or so, it saves the session (if changes exist in it), to "~/xcas_auto_XXXXXXXX.xws".

Unfortunately, this seemingly nice feature makes life unbearable for Linux users:

After autosaving, xcas moves the focus to its window. So if the user is busy doing some other task (browsing the internet, writing an article, playing solitaire, ...), he's suddenly switched to xcas. This is highly annoying. It means that every minute or so (maybe less) I need to switch back to the application I was yanked out of.

The problem exists in all the window managers I tried:

- xmonad
- LXDE
- jwm

(I don't have Unity, sorry.)

(In LXDE the problem is less acute: the user can put xcas in a separate desktop to alleviate the problem, as xcas won't cause the current desktop to change. But in the other window managers this workaround doesn't work: xcas does switch the desktop to the one it's on.)

parisse
Messages : 5084
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: "autosave" feature moves focus to the application

Message par parisse » dim. mai 26, 2019 4:24 pm

Xcas 1.2.3 is really old, you should upgrade to Xcas 1.5.0.

niccolo
Messages : 22
Inscription : dim. mars 02, 2014 2:13 pm

Re: "autosave" feature moves focus to the application

Message par niccolo » dim. mai 26, 2019 5:44 pm

Thanks: I upgraded to 1.5.0 and the problem is gone.

niccolo
Messages : 22
Inscription : dim. mars 02, 2014 2:13 pm

Re: "autosave" feature moves focus to the application

Message par niccolo » lun. juin 22, 2020 3:23 pm

(A year has passed.)

An update:

I've upgraded to Ubuntu 20.04, and installed xcas 1.5.0 (using Ubuntu's official package manager).

The problem has returned: 'xcas' steals the focus. Highly annoying.

I found two solutions:

(1) Before switching to some other app, save the session.

(2) Before switching to some other app, switch (inside xcas) to a tab that doesn't contain unsaved modifications. E.g., click "File > New session".

And, as I mentioned earlier, with some Window Managers you can solve the problem by putting xcas on a separate desktop. This works in LXDE (as I mentioned), and I now see that it works in GNOME too, but GNOME would pop up an annoying notification message ("FLTK, Xcas 1.5.0 (linux 64) is ready") whenever xcas asks for the focus (a workaround: turn on "Do Not Disturb", but this has consequences).

(To the list of Window Managers for which you can not solve the problem by moving xcas to a separate desktop I now add XFCE.)

parisse
Messages : 5084
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: "autosave" feature moves focus to the application

Message par parisse » mer. juin 24, 2020 5:51 pm

Nothing has changed in Xcas in the auto-save code, it's still working with old distributions (here on debian7 and xfce). If it does not work with new distributions, I have no idea what can be done. Perhaps a new version of FLTK is required because X11 made some changes (in that case the packaged version of giac should work since they are certainly using the latest FLTK version).

Répondre