sym2poly/r2sym( ... ) Error: Bad Argument Value

Bugs

Modérateur : xcasadmin

O.C.
Messages : 11
Inscription : dim. août 30, 2009 9:53 pm

sym2poly/r2sym( ... ) Error: Bad Argument Value

Message par O.C. » mar. sept. 01, 2009 6:10 pm

Bonjour,

j'ai un bug en faisant : int(exp(-T^2*w^2)*w^2,w,-infinity,+infinity)
"sym2poly/r2sym(const gen & e,const index_m & i,const vecteur & l) Error: Bad Argument Value"

Je ne pense pas abuser outrageusement de la syntaxe, donc je crois que c'est un bug.

Cordialement,

O.C.

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: sym2poly/r2sym( ... ) Error: Bad Argument Value

Message par parisse » mer. sept. 02, 2009 8:59 am

oui, c'est bien un bug, merci!
je suis en train de le corriger, le source et la version linux xcas_root vont etre mises a jour d'ici quelques minutes, il faudra plus de temps pour les autres versions.

O.C.
Messages : 11
Inscription : dim. août 30, 2009 9:53 pm

Re: sym2poly/r2sym( ... ) Error: Bad Argument Value

Message par O.C. » mer. sept. 02, 2009 11:47 am

parisse a écrit :je suis en train de le corriger, le source et la version linux xcas_root vont etre mises a jour d'ici quelques minutes.
J'ai testé : ça marche. Merci pour la correction !

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: sym2poly/r2sym( ... ) Error: Bad Argument Value

Message par parisse » mar. sept. 08, 2009 9:13 am

Bon, je suis devant un dilemne. En ameliorant la primitive pour qu'elle ne contienne plus de valeur absolue dans erf et en-dehors, le probleme du unsigned inf revient sauf si on fait une hypothese sur T. Vaut-il mieux une primitive plus simple sans valeur absolue et devoir faire une hypothese sur T ou vaut-il mieux des valeurs absolues de T dans la primitive? Pour l'instant, j'ai choisi la 1ere solution.

Répondre