pb affichage 'pretty print' en sortie sous Windows

Bugs

Modérateur : xcasadmin

ldemay
Messages : 2
Inscription : jeu. juin 21, 2007 7:45 pm

pb affichage 'pretty print' en sortie sous Windows

Message par ldemay » ven. juin 22, 2007 11:42 am

Bonjour,

Tout d'abords, félicitation pour le remarquable travail réalisé.
Je suis enseignant en Maths et Informatique et après avoir utilisé la TI-92 puis MuPad ou Maxima pour mes TPs, je compte passer à Xcas.

J'ai remarqué un petit 'bug' sous Windows depuis la version avec la dll et qui n'était pas présent avant (v 0.6.2).
Le formatage 'pretty print' en sortie ne se fait pas toujours correctement :
Si on entre 'x^2' on obtient bien x², mais si on tape 'x^2+1' , l'exposant est alors écrit x^2 en mode texte. Mais chose pour 'sqrt(2)' qui est correctement affiché √2 alors que 'sqrt(50)' donne 5*sqrt(2).

parisse
Messages : 5082
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » ven. juin 22, 2007 6:39 pm

bizarre, ca a l'air de marcher sous linux, je regarderai sous windows quand j'aurai une machine sous la main, la semaine prochaine.
merci!

ldemay
Messages : 2
Inscription : jeu. juin 21, 2007 7:45 pm

Message par ldemay » ven. juin 22, 2007 10:32 pm

Je confirme que cela fonctione bien par contre sous Linux (testé avec Ubuntu et la derniere version de giac du 19/06/07).

parisse
Messages : 5082
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » lun. juin 25, 2007 1:09 pm

ca devrait marcher maintenant, meme si je ne suis pas satisfait par la correction que j'ai du apporter, il semble qu'il y a un probleme au chargement d'une adresse d'une fonction de la DLL.

Répondre