1.0 pre-release

Nouveautes concernant Xcas.
News about Xcas

Modérateur : xcasadmin

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: 1.0 pre-release

Message par frederic han » mer. nov. 28, 2012 2:13 pm

Salut,

J'ai toujours des problemes de curseur qui change tout seul de ligne (mais je crois que ca le fait aussi avec d'autre versions)

J'ai peut etre une piste avec la 1.0

faisons:

normal(3) puis entree
puis
33 puis entree.

alors
si je retourne trafiquer la ligne du normal avec le clavier. Ex fleches haut puis j'insere un espace entre r et m et le le detruit avec backspace j'arrive a faire disparaitre le pointeur de la souris qui a une forme de fleche)

ensuite je laisse le curseur a cet endroit (mais ca arrive aussi lorsque l'on continue a travailler sur cette ligne) j'attend une minute et la le curseur saute a la ligne du 33 ce qui est genant lorsque l'on etait en train de taper.


Bref j'ai l'impression que le probleme ne survient que lorsque l'on a fait disparaitre le pointeur de la souris. Si apres avoir fait disparaitre le pointeur je bouge la souris pour le faire reapparaitre ca ne le fait pas.

Est ce que tu arrives a le reproduire?

Fred

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: 1.0 pre-release

Message par parisse » mer. nov. 28, 2012 4:48 pm

Effectivement. Je pense que c'est au moment de la sauvegarde automatique. Xcas_input_focus semble non positionné sur le 1er widget, va savoir pourquoi...

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: 1.0 pre-release

Message par parisse » mer. nov. 28, 2012 5:19 pm

Bon, ben non, ce n'est pas la sauvegarde automatique. Je n'ai aucune idée de ce qui provoque le changement de focus:-(
Heureusement que ça ne se produit pas souvent...

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: 1.0 pre-release

Message par frederic han » mer. nov. 28, 2012 6:14 pm

Salut,
Si je pense que ca vient de la sauvegarde auto. Je peux faire rm xcas_auto_ et ls xcas_auto* dans un terminal et le fichier arrive bien juste au changement de focus.

NB: Ca se produit si je remonte a la ligne du depart avec les fleche du clavier, mais pas si je clique avec la souris, donc ca depend des gens mais ca peut etre tout de meme frequent.

Fred

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: 1.0 pre-release

Message par parisse » mer. nov. 28, 2012 6:58 pm

tu as raison, je m'étais trompé de méthode ::save_as pour tracer le problème.
Je pense que rajouter un
hp->_sel_begin=-1;
en ligne 3084 de Editeur.cc devrait régler le problème.

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: 1.0 pre-release

Message par frederic han » jeu. nov. 29, 2012 9:13 am

Je viens d'essayer avec le code source du 29/11 ca a l'air de marcher.
ouf!

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: 1.0 pre-release

Message par parisse » lun. déc. 10, 2012 2:34 pm

Je suis en train de finir (encore!) une mise a jour de la 1.0. Comme on ne m'a rien signale d'important la semaine derniere, c'est peut-etre la bonne (enfin bon, il y a surement encore des bugs, j'ai corrige ce matin meme ranm(2,2,0..1) qui ne renvoyait que des 0).
En tout cas, j'ai commence une branche 1.1 et je ne backporterai que les corrections de bugs importantes vers la 1.0 (ainsi que des changements hors binaires, comme par exemple corrections dans le fichier de francisation ou dans les menus ou ajout de traductions de mots clefs).
Premier changement pour la 1.1, les flottants hardware vont gagner 3 bits de precision (mantisse codee sur 48 bits au lieu de 45) (sauf sous windows ou je compile avec -DDOUBLEVAL donc des gen sur 96 bits et donc des flottants avec une mantisse sur 53 bits), le champ type d'un gen etant reduit a 5 bits au lieu de 8 (soit 32 types possibles dont 22 occupes). Ainsi 3*1/3.-1 renverra -3.55...e-15.

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: 1.0 pre-release

Message par parisse » lun. janv. 07, 2013 2:45 pm

Nouvelle mise a jour de la 1.0, avec les correctifs des bugs signales pendant les vacances de Noel.
Bonne rentree a tous!

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: 1.0

Message par parisse » mar. avr. 02, 2013 1:31 pm

Nouvelle mise a jour de la 1.0.0, pour qu'on la reconnaisse, je lui ai mis un -5 pour le package deb sous linux et un -5 dans version() sous mac et win.

Répondre