0.8.1 linux en avant-premiere

Nouveautes concernant Xcas.
News about Xcas

Modérateur : xcasadmin

Répondre
parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

0.8.1 linux en avant-premiere

Message par parisse » ven. août 15, 2008 8:20 am

Bonjour a tous,
j'ai mis en telechargement une version preliminaire linux de xcas 0.8.1. La principale nouveaute ce sont les sessions qui sont independantes. Amelioration pour la sauvegarde et la restauration de sessions (sauf sauvegarde automatique): le contexte (variables, mode, etc.) est sauvegarde avec la session.
Liens
ftp://ftp-fourier.ujf-grenoble.fr/xcas/ ... stable.tgz,
http://www-fourier.ujf-grenoble.fr/~par ... stable.tgz
Il faut desarchiver l'archive la ou sont installes les binaires de xcas (/usr/local/bin si vous utilisez xcas_root.tgz, /usr/bin pour un package debian).
Commentaires bienvenus!

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » mer. août 20, 2008 5:02 pm

Salut, j'ai fait un petit test:

j'ai un soucis avec un fichier session.xws contenant juste le code:

f:=proc(A)
b:=[seq(1,i=1..5)];
for i from 2 to 5 do
b:=2;
od;
b;
end proc;f(1)

(ca sert a rien c'est juste pour isoler l'erreur)

si je fais:

xcas session.xws puis F9 ca marche sans Pb.

si je fais
xcas , que je laisse la session vide, puis que j'ouvre avec alt O le fichier session.xws alors xcas quitte brutalement.

(NB: ma config par defaut est en mode maple, je ne sais pas si c'est relie)

a+ et bon courage

Fred

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » mer. août 20, 2008 7:15 pm

en effet, petit oubli que je viens de corriger.
Ce n'est sans doute pas le dernier:-(
Merci et a+

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » mer. août 27, 2008 9:13 pm

OK pour la correction ca marche.

Je n'ai pas beaucoup teste, mais je note aussi ca:

restart ne purge plus les variables alors qu'avant si:

a:=2
restart
a
me donne encore 2

purge(a) fonctionne.

Mais en revanche lorsque l'on purge une variable non affectee, la suite de la ligne n'est plus lue:

purge(b);c:=3

donne No such variable b Error: Bad Argument Value

et c non affecte, alors qu'avant:

ca faisait:
"b not assigned",3

et c vallait bien 3

Tant que j'y suis, il y a un truc present dans toutes les versions et je me demande si ca ne gene que moi:

la touche page up fait remonter le curseur mais une fois qu'il arrive en debut de fichier, il repart a la fin, alors que la touche page down ne fait pas revenir au debut. Serait il possible/souhaitable de bloquer le page up en debut de fichier lorsque l'on appuie trop longtemps?

a+
Fred

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » mer. août 27, 2008 9:45 pm

Encore une remarque:

avec la nouvelle version:
en mode geometrie 2D par exemple,
si je fais:

t:=element(-1..1,0)
...

je n'ai plus la figure se dessine bien, mais le petit bouton pour faire bouger t n'apparait plus.

Si je sauve avec l'ancienne version, lorsque je l'ouvre avec la nouvelle, j'ai le petit bouton, mais il disparait lorsque j'execute.

Fred

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » jeu. août 28, 2008 10:45 am

merci pour les bugs reports!
ca devrait fonctionner avec la version que je viens de mettre a jour.
a+

dlefur
Messages : 60
Inscription : dim. mai 04, 2008 1:58 pm
Localisation : São Paulo, Brésil
Contact :

Message par dlefur » lun. sept. 08, 2008 9:13 am

Bonjour,

e viens d'installer la version xcas 0.8.1.

Je cherchais le numéro de la version. Dans le message, on me dit que c'est la 0.7.0.
C'est normal ?

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » lun. sept. 08, 2008 10:29 am

sous win ou sous linux?
j'ai du oublier de changer VERSION quelque part...

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » lun. sept. 08, 2008 12:42 pm

Oui, ca me le fait toujours avec toutes les versions de xcas_root et xcas_user
mais pas avec les .deb ni les sources
Fred

dlefur
Messages : 60
Inscription : dim. mai 04, 2008 1:58 pm
Localisation : São Paulo, Brésil
Contact :

Message par dlefur » lun. sept. 08, 2008 1:36 pm

C'est sous Linux.

Répondre