test support utf8

Nouveautes concernant Xcas.
News about Xcas

Modérateur : xcasadmin

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

test support utf8

Message par parisse » jeu. nov. 19, 2009 4:40 pm

Ce sont deux versions de test pour windows et mac du support UTF8, xcasinst.exe pour win et par ftp sur ftp-fourier.ujf-grenoble.fr/xcas, xcas_osxutf8.dmg.gz (mac). Sur la version mac, il faut lancer à partir de xcasfr.command sinon je ne suis pas sur que ca marche (je ne sais pas si c'est une fausse manip de ma part ou un probleme de la nouvelle version de FLTK utilisée). Il s'agit d'avoir un support correct de l'UTF8 pour les traductions en langues non latines d'une part, et d'autre part diverses améliorations (dont la taille de la session non limitée à 16000 pixels).

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: test support utf8

Message par parisse » mar. nov. 24, 2009 10:10 am

La version linux xcas_root/user devrait etre aussi en mode UTF8 maintenant. Du fait de changements de la librairie graphique FLTK, elle n'est plus autant statiquement liee qu'auparavant, ldd xcas renvoie
linux-gate.so.1 => (0xb80d7000)
libXft.so.2 => /usr/lib/libXft.so.2 (0xb8093000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb801d000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb8012000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xb7f23000)
libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0xb7f1f000)
libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0xb7f06000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7e18000)
libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0xb7df2000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7de2000)
libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0xb7c84000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb7c57000)
libz.so.1 => /usr/lib/libz.so.1 (0xb7c41000)
libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb7c3e000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7c24000)
/lib/ld-linux.so.2 (0xb80bd000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7bfd000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xb7bfa000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb7bf5000)
J'espere que ca passera bien. Si personne n'a de problemes, je passerai alors la version debian package avec la nouvelle version de FLTK.

Répondre