Avira antivir detect a virus in the windows package 0.86 !

Nouveautes concernant Xcas.
News about Xcas

Modérateur : xcasadmin

fjhdavid
Messages : 13
Inscription : mar. mars 23, 2010 8:42 am

Avira antivir detect a virus in the windows package 0.86 !

Message par fjhdavid » mar. mars 23, 2010 9:04 am

Dear all,

My Avira antivir has detected the troyan horse: "html/crypted.gen" in the last windows build 0.86 (22 mars 2010).
I run windows seven 64 bits with an uptaded antivir.

The virus was detected yesterday evening, as I try to install the package.

thanks for your feedback

Francois

parisse
Messages : 5112
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par parisse » mar. mars 23, 2010 3:34 pm

Can you give more details? I mean what is the file that your antivirus is claiming to be infected?

fjhdavid
Messages : 13
Inscription : mar. mars 23, 2010 8:42 am

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par fjhdavid » mar. mars 23, 2010 4:04 pm

the file which is claiming to be infected is: xcasinst.exe (27 829 536 octets), it is the windows build 0.86

I use avira antivir personnal 9.0

parisse
Messages : 5112
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par parisse » mar. mars 23, 2010 6:22 pm

You should be able to find more details, since the file xcasinst.exe is an auto-extractible archive (generated by nullsoft installer), if your antivirus detects a virus, it should give you the name of a specific file of the archive.
BTW, there is almost certainly *no virus* in xcasinst.exe, it is a false positive detection. I just want to know which file is responsible for the false positive.

fjhdavid
Messages : 13
Inscription : mar. mars 23, 2010 8:42 am

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par fjhdavid » mar. mars 23, 2010 6:50 pm

je suis alle sur l'adresse:
http://www-fourier.ujf-grenoble.fr/~par ... ll_en.html
apres

je clique sur HTTP ou sur FTP dans la premiere ligne du paragraphe "Xcas for Windows" , a savoir:

Download the installer: stable (0.8.6, March 22, 2010): HTTP or by FTP.

apres j'ai le rapport suivant de antivir:
-------------------------------------------------------------------------------------
Début de la recherche : mardi 23 mars 2010 19:47

La recherche sur les fichiers sélectionnés commence :

Recherche débutant dans 'C:\Users\Francesco\Desktop\xcasinst.exe'
C:\Users\Francesco\Desktop\xcasinst.exe
[0] Type d'archive: NSIS
--> ProgramFilesDir/lwN
[RESULTAT] Contient le modèle de détection du virus de script HTML HTML/Crypted.Gen
--> ProgramFilesDir/lwN1
[RESULTAT] Contient le modèle de détection du virus de script HTML HTML/Crypted.Gen

------------------------------------------------------------------------------

parisse
Messages : 5112
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par parisse » mar. mars 23, 2010 6:55 pm

lwN et lwN1 sont deux fichiers textes contenant des scripts giac pour deux problèmes de benchmark de PGCD (de la suite de Lewis-Wester). Je vérifierai demain qu'ils n'ont pas été altérés (mais je n'y crois pas:-)). Je pense que c'est bien un faux positif de l'antivirus, ceci dit ils ne sont pas indispensables loin de là je les enleverai de la version windows pour éviter ce genre de problèmes.

fjhdavid
Messages : 13
Inscription : mar. mars 23, 2010 8:42 am

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par fjhdavid » mar. mars 23, 2010 7:04 pm

ok

merci

parisse
Messages : 5112
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par parisse » mer. mars 24, 2010 10:00 am

je viens de mettre a jour la version windows de xcas, en enlevant lwN/lwN1, j'espere que ca passe maintenant.

fjhdavid
Messages : 13
Inscription : mar. mars 23, 2010 8:42 am

Re: Avira antivir detect a virus in the windows package 0.86 !

Message par fjhdavid » mer. mars 24, 2010 10:03 am

ca marche parfaitement! plus de faux virus detecté et le logiciel tourne aussi bien que sur mon iphone!

Répondre