version 0.9.3 definitive(?)

Nouveautes concernant Xcas.
News about Xcas

Modérateur : xcasadmin

Répondre
parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

version 0.9.3 definitive(?)

Message par parisse » lun. sept. 19, 2011 12:48 pm

Les source et binaires 0.9.3 (win 32 bits, linux 32 et 64 bits, mac os x.6) ont ete mis a jour, pour (j'espere) la version 0.9.3 finale.

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: version 0.9.3 definitive(?)

Message par parisse » ven. sept. 23, 2011 1:47 pm

Bon, j'ai refait une mise à jour de la 0.9.3 avec qques bugs corrigés, sqrt coché par défaut à l'installation, du mauve pour plotseq (qui j'espère sera plus visible avec un vidéoprojecteur), et un signe * un tout petit peu plus grand.

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: version 0.9.3 definitive(?)

Message par frederic han » mar. sept. 27, 2011 9:36 am

J'ai un pb d'install du paquet amd64 sur une debian stable.

il y a une dependance sur: libmpfr1ldbl qui n'est pas installable, mais il y a des libmpfr4


Fred

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: version 0.9.3 definitive(?)

Message par parisse » mar. sept. 27, 2011 1:18 pm

bon, j'ai recompile avec mpfr en statique, j'espere que ca ne pose plus de pb de dependances!

alb
Messages : 1239
Inscription : ven. août 28, 2009 3:34 pm

Re: version 0.9.3 definitive(?)

Message par alb » mar. sept. 27, 2011 8:11 pm

J'ai bien la mise à jour du 23 septembre sous windows mais sous linux 32 bits rien de nouveau
la commande sudo apt-get install giac me renvoie
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
giac est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
libhsqldb-java libservlet2.5-java xaw3dg
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: version 0.9.3 definitive(?)

Message par parisse » mer. sept. 28, 2011 9:28 am

Que se passe-t-il si vous faites sudo apt-get update avant sudo apt-get install giac?
Ou bien directement depuis xcas, menu Fichier -> Quitter et mettre a jour?

alb
Messages : 1239
Inscription : ven. août 28, 2009 3:34 pm

Re: version 0.9.3 definitive(?)

Message par alb » mer. sept. 28, 2011 6:56 pm

Finalement, comme tout échouait (y compris Quitter et mettre à jour), j'ai installé à la main le paquet giac 0.9.3 pour i386
J'ai donc maintenant la dernière version stable
Si j'ai dans mon sources.list:
# deb http://www-fourier.ujf-grenoble.fr/~parisse/debian/ stable main
deb http://www-fourier.ujf-grenoble.fr/~parisse/debian/ testing main
j'obtiens avec apt-get update
Ign http://www-fourier.ujf-grenoble.fr testing Release.gpg
Ign http://www-fourier.ujf-grenoble.fr/~parisse/debian/ testing/main Translation-fr
Ign http://www-fourier.ujf-grenoble.fr testing Release
Ign http://www-fourier.ujf-grenoble.fr testing/main Packages
Ign http://www-fourier.ujf-grenoble.fr testing/main Packages
Atteint http://www-fourier.ujf-grenoble.fr testing/main Packages
puis apt-get install giac
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
giac est déjà la plus récente version disponible.

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: version 0.9.3 definitive(?)

Message par parisse » ven. sept. 30, 2011 10:34 am

je pense que j'avais du faire une mauvaise manip. On verra ce que ca donne avec la maj d'aujourd'hui...

alb
Messages : 1239
Inscription : ven. août 28, 2009 3:34 pm

Re: version 0.9.3 definitive(?)

Message par alb » ven. sept. 30, 2011 12:15 pm

Cela signifie-t-il que tout s'est bien passé ?
Réception de : 1 http://www-fourier.ujf-grenoble.fr/~parisse/debian/ testing/main giac 0.9.3-1 [28,5MB]
28,5Mo réceptionnés en 1min 57s (243ko/s)
(Lecture de la base de données... 521745 fichiers et répertoires déjà installés.)
Préparation du remplacement de giac 0.9.3-1 (en utilisant .../archives/giac_0.9.3-1_i386.deb) ...
Dépaquetage de la mise à jour de giac ...
Traitement des actions différées (« triggers ») pour « man-db »...
Traitement des actions différées (« triggers ») pour « install-info »...
Traitement des actions différées (« triggers ») pour « desktop-file-utils »...
Traitement des actions différées (« triggers ») pour « python-gmenu »...
Rebuilding /usr/share/applications/desktop.fr_FR.utf8.cache...
Traitement des actions différées (« triggers ») pour « python-support »...
Paramétrage de giac (0.9.3-1) ...
Ignoring install-info called from maintainer script
The package giac should be rebuilt with new debhelper to get trigger support
Ignoring install-info called from maintainer script
The package giac should be rebuilt with new debhelper to get trigger support
Traitement des actions différées (« triggers ») pour « libc-bin »...
ldconfig deferred processing now taking place

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: version 0.9.3 definitive(?)

Message par parisse » ven. sept. 30, 2011 1:34 pm

en effet, c'est normal.

Répondre