Installation impossible sur Jessie

Bugs

Modérateur : xcasadmin

guy
Messages : 18
Inscription : lun. oct. 15, 2012 12:36 pm

Re: Installation impossible sur Jessie

Message par guy » lun. déc. 08, 2014 10:46 am

parisse a écrit :Voila, j'ai mis le 1.1.13 dans le répertoire source debian (mais sans avoir ajoute le scan, il n'y a pas de Package.gz).
Merci.

Voilà ce que j'ai fait pour compiler giac/xcas sous jessie en tant que user "sudoer"

Code : Tout sélectionner

cd /tmp
wget http://www-fourier.ujf-grenoble.fr/~parisse/debian/dists/stable/main/source/giac_1.1.3-12.tar.gz
tar xf giac_1.1.3-12.tar.gz 
cd giac-1.1.3
dpkg-buildpackage -uc -b -j4
# Donne la liste des dépendances manquantes (à installer). 
# de même que libfltk1.3-dev qui n'est pas marqué comme 
# dépendance obligatoire dans les sources devra être installé
# si on veut un affichage graphique ...
sudo aptitude install libfltk1.3-dev
dpkg-buildpackage -uc -b -j4
sudo dpkg -i *giac*_amd64.deb
A noter quelques warnings faciles à corriger dans les sources
debian/changelog Date incorrecte en lignes 3 et 7 remplacer le
1er 'Dec' par 'Mon'

--
Guy

guy
Messages : 18
Inscription : lun. oct. 15, 2012 12:36 pm

Re: Installation impossible sur Jessie

Message par guy » ven. déc. 12, 2014 4:26 pm

Pour info, le problème de dépendances semble réglé sous sid/jessie avec la version 1.1.3-13.
Plus besoin de recompiler soi-même :-)
Merci.
ben en fait non :-(
Le problème n'est pas réglé
Dernière modification par guy le ven. févr. 06, 2015 10:59 am, modifié 2 fois.

bvin
Messages : 19
Inscription : ven. oct. 19, 2007 4:58 pm
Localisation : hérault

Re: Installation impossible sur Jessie

Message par bvin » sam. déc. 13, 2014 5:25 am

Bizarre, pas chez moi.

parisse
Messages : 5082
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: Installation impossible sur Jessie

Message par parisse » sam. déc. 13, 2014 7:15 am

Peut-etre parce que pour tester que ca ne cree pas de conflits, je n'ai mis le paquet jpeg que dans la branche testing, pas dans stable. Si j'ai confirmation que c'est bien ca, je le copierai dans stable.

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: Installation impossible sur Jessie

Message par frederic han » lun. janv. 05, 2015 2:24 pm

Avec la branche stable pour giac et jessie j'avais toujours ce probleme de deps, (il me semble avoir essaye de forcer l'install de libjpeg62, mais il etait en conflit avec -turbo)

j'ai fais un paquet giac-1.1.3-16 sur jessie pour amd64:
avec aussi le paquet python3-giacpy qui depend sur jessie de python 3.4.
(j'ai mis aussi qcas et python-giacpy mais eux marchaient)

Code : Tout sélectionner

deb http://webusers.imj-prg.fr/~frederic.han/debian jessie main

Cheval
Messages : 66
Inscription : mar. sept. 24, 2013 7:51 pm

Re: Installation impossible sur Jessie

Message par Cheval » ven. janv. 30, 2015 8:33 am

Bonjour,
j'ai essayé les deux offres de Frédéric Han, le paquet deb et les dépôts.
En fait, j'ai une machine 32 bits, donc le paquet deb qui doit être exclusif 64 est refusé.
Pour le dépôt, ça doit être pareil, mais après avoir mis le dépôt dans le fichier sources.list et rechargé les infos dans synaptic, quand je tape "giac" dans la fenêtre de recherche, je n'ai rien…
Dommage, pour moi, c'est simple, cette debian jessie / LXDE tourne très bien sur mes vieilleries, mais sans Xcas point de salut, si je ne trouve pas de solution pour installer, je jette la debian.

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: Installation impossible sur Jessie

Message par frederic han » ven. janv. 30, 2015 10:14 am

Effectivement je n'ai rien fait pour jessie 32 bits
desole

Frederic

parisse
Messages : 5082
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Re: Installation impossible sur Jessie

Message par parisse » ven. janv. 30, 2015 3:08 pm

Et le "vieux" paquet i386 http://www-fourier.ujf-grenoble.fr/~par ... 6_i386.deb? Par vieux, j'entends compile sur un linux antique et avec tres peu de dependances.

Cheval
Messages : 66
Inscription : mar. sept. 24, 2013 7:51 pm

Re: Installation impossible sur Jessie

Message par Cheval » ven. janv. 30, 2015 3:49 pm

@ Frédéric Han : faut pas être désolé, vous avez mis une roue de secours pour les 64 bits, c'est déjà sympa !
@ Bernard Parisse : j'ai tenté plusieurs trucs en partant du site de Qcas, où j'ai retrouvé le dépôt giac et j'ai cliqué sur la 1.1.3-22 en i386, au final, il m'a chargé et tenté d'installer une 1.1.4-1 (??? pas compris !) => ça a foiré et en prime j'ai cassé des paquets, et je n'arrive pas à réparer.
Je vais tâcher de réinstaller cette debian plus proprement, de la mettre à jour avant de charger des logiciels et on verra…
Au cas où, j'essaierai la 1.1.3-16.

Cheval
Messages : 66
Inscription : mar. sept. 24, 2013 7:51 pm

Re: Installation impossible sur Jessie

Message par Cheval » ven. janv. 30, 2015 6:32 pm

J'ai tout réinstallé ma debian jessie / Lxde, mis à jour, j'ai chargé le "vieux" paquet giac 1.1.3-16 (à partir de la page de téléchargement du site) et je l'ai installé sans histoires avec Gdebi (il m'a téléchargé 2 dépendances et c'est ok)
Ca roule !
Merci de l'aide

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: Installation impossible sur Jessie

Message par frederic han » dim. févr. 01, 2015 1:00 pm

Cheval a écrit :@ Frédéric Han : faut pas être désolé, vous avez mis une roue de secours pour les 64 bits, c'est déjà sympa !
@ Bernard Parisse : j'ai tenté plusieurs trucs en partant du site de Qcas, où j'ai retrouvé le dépôt giac et j'ai cliqué sur la 1.1.3-22 en i386, au final, il m'a chargé et tenté d'installer une 1.1.4-1 (??? pas compris !) => ça a foiré et en prime j'ai cassé des paquets, et je n'arrive pas à réparer.
Je vais tâcher de réinstaller cette debian plus proprement, de la mettre à jour avant de charger des logiciels et on verra…
Au cas où, j'essaierai la 1.1.3-16.
Sur le site de Qcas il y a juste un lien vers les depots de bernard:
http://www-fourier.ujf-grenoble.fr/~parisse/debian

guy
Messages : 18
Inscription : lun. oct. 15, 2012 12:36 pm

Re: Installation impossible sur Jessie

Message par guy » lun. févr. 02, 2015 5:46 pm

Bonsoir,

J'ai fait un petit script qui downloade le binaire et le corrige pour une install sans problème de dépendances (libjpeg62-turbo) sous debian jessie/sid. J'en profite pour modifier le numéro de version pour éviter que la version du dépôt n'écrase le paquet installé "patché" ...

Il faut :
- que le paquet aptitude soit installé (pour le download)

Code : Tout sélectionner

sudo apt-get install aptitude
- que le dépôt soit correctement configuré

Code : Tout sélectionner

$ cat /etc/apt/sources.list.d/xcas.list
### giac xcas
deb http://www-fourier.ujf-grenoble.fr/~parisse/debian/ testing main
Voici le code du script, si ça peut intéresser quelqu'un (... sans garanties) :

Code : Tout sélectionner

$ cat bin/fixgiac.sh 
#!/bin/bash
# script pour modifier le paquet binaire giac (compatibilité debian jessie)
echo "## Penser à faire (avant de lancer ce script) :"
echo "sudo aptitude update"

version=$(apt-cache policy giac | grep "Candidat" | cut -d":" -f2 | tr -d " " | sed -e "s/a$//")
arch=$(dpkg --print-architecture)

if [[ -z $version ]] ; then
 echo "Vérifier que le dépôt pour giac est correctement configuré ..."
 exit 1
fi

otmp=$(cd)
dtmp=$(mktemp -d)
trap "rm -rf ${dtmp}" EXIT
cd ${dtmp}
aptitude download giac=${version}
mkdir tmp && cd $_
ar x ../giac_${version}_${arch}.deb 
mkdir control && cd $_
tar xf ../control.tar.gz
sed -i -e "s/libjpeg62 /libjpeg62-turbo | libjpeg62 /" \
       -e "s/^Version\(.*\)$/Version\1a/" control
rm -f ../control.tar.gz 
tar -zcf ../control.tar.gz ./
cd ..
ar rc /tmp/giac_${version}a_${arch}.deb  debian-binary control.tar.gz data.tar.gz
cd ${otmp}

echo "## Pour installer le paquet giac corrigé faire :"
echo "sudo dpkg -i /tmp/giac_${version}a_${arch}.deb"
echo " -ou-"
echo "sudo gdebi /tmp/giac_${version}a_${arch}.deb"
Dernière modification par guy le ven. févr. 06, 2015 10:21 am, modifié 1 fois.

guy
Messages : 18
Inscription : lun. oct. 15, 2012 12:36 pm

Re: Installation impossible sur Jessie

Message par guy » mar. févr. 03, 2015 8:46 am

Bonjour,

Je n'utilise pas python3 mais je remarque qu'il n'est pas possible d'installer
le paquet python3-giacpy sur debian jessie. Y a t-il une raison a empêcher
cette installation pour une version de python3 >= à 3.3 ?

Merci.

Code : Tout sélectionner

$ sudo aptitude install python3-giacpy
Les NOUVEAUX paquets suivants vont être installés :     
  python3-giacpy{b} 
0 paquets mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 1 442 ko d'archives. Après dépaquetage, 3 908 ko seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 python3-giacpy : Dépend: python3 (< 3.3) mais 3.4.2-2 est installé.
Les actions suivantes permettront de résoudre ces dépendances :

     Conserver les paquets suivants dans leur version actuelle :
1)     python3-giacpy [Non installé]                            



Accepter cette solution ? [Y/n/q/?] 

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: Installation impossible sur Jessie

Message par frederic han » mar. févr. 03, 2015 1:09 pm

A priori les paquets pour python contiennent une version de la librairie pour chaque version de python supportee par la distribution. Comme debian stable s'arrete a python3.2 le paquet cree sur debian stable ne va pas plus loin.
Forcer une 3.2 avec une 3.3 peut eventuellement marcher mais jessie est sous 3.4 et la je pense que ca ne marche pas.
C'est surtout d'avoir python3-giacpy pour python 3.4 qui m'avait motive pour faire des paquets pour jessie:


http://webusers.imj-prg.fr/~frederic.ha ... nary-amd64

frederic

Cheval
Messages : 66
Inscription : mar. sept. 24, 2013 7:51 pm

Re: Installation impossible sur Jessie

Message par Cheval » mar. févr. 03, 2015 3:18 pm

@ Frédéric Han : oui je sais, c'est la liste des dépôts, j'avais pas percuté qu'on l'avait aussi depuis le site Xcas :(

Sinon, tout est à refaire !
Je viens d'installer Jessie sur mon eeepc 701 : ça marche du feu de dieu (boot en 31s), je l'ai installée à partir du même CD que celle que j'ai installée sur une carte SD et avec laquelle j'ai pu mettre la version 1.1.3-16 avec juste 2 dépendances qu'à résolues Gdebi sans pb. Là, pas question, la même manip ne marche pas.
J'ai aussi essayé la super vieille 1.1.2-10 : exactement pareil, c'est dans les deux cas libgmp3c2 qui pose pb (la dépendance ne peut être satisfaite dixit Gdebi).
Si j'essaye la 1.1.4-1 via les dépôts, j'obtiens ça :

Code : Tout sélectionner

giac:
 Dépend : libao4 mais ne doit pas être installé
 Dépend : libatlas3gf-base mais ne doit pas être installé
 Dépend : libgmp3c2 mais ne doit pas être installé
 Dépend : libgsl0ldbl mais ne doit pas être installé
 Dépend: libjpeg62 (>= 6b1)
 Recommande : python3-giacpy mais ne doit pas être installé
 Recommande : python-giacpy mais ne doit pas être installé
Si j'ai pas Xcas sur cette machine, je laisse tomber Jessie, mais franchement, vu comment ça tourne, ça m'embête un peu…

@ Guy : ça pourrait m'intéresser, mais j'ai entendu dire qu'on ne peut pas mélanger synaptic et aptitude sous peine de déboires. Or, j'ai tout installé sous synaptic.

Répondre