enable-qcas option

sagitter
Messages : 21
Inscription : sam. mai 14, 2016 6:19 pm
Localisation : Italy

enable-qcas option

Message par sagitter » dim. déc. 17, 2017 5:27 pm

Hi all.

giacpy-0.6.2/setup.py file reports this text:

Code : Tout sélectionner

###############################################################
#If you have QT support, you can enable qcas with --enable-qcas
#    But to use qcas you should create first: qcas/libqcas.a with:
#       qmake libqcas.pro ;make
import sys
if "--enable-qcas" in sys.argv:
    USE_QCAS=True
    sys.argv.remove("--enable-qcas")
else:
    USE_QCAS=False
#######################################
Is this option usable?
Does giacpy really need libqcas.a library for supporting QCAS?
mailto: sagitter 'at' fedoraproject 'dot' org
https://fedoraproject.org/wiki/User:Sagitter
GPG Key: 0x5E212EE1D35568BE
Check on https://keys.fedoraproject.org/

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: enable-qcas option

Message par frederic han » dim. déc. 17, 2017 9:16 pm

Well, it works for me but it was just a quick trick to do the job and I didn't have time to clean or improve things, so it is disabled by default
.

Technically you can switch to dynamic lib:
comment the:

CONFIG+=staticlib
in the unix section and do:

qmake-qt5 libqcas.pro
make

then install the libqcas libs somewhere in the librarypath. (/usr/lib64 looks to work for me), but the current qcas don't use it, it would only be shared by the different giacpy2qcas (python2 and 3) .

quick test in a python console:

Code : Tout sélectionner

import giacpy
A=giacpy.plot('sin(x)')
A.qcas()

sagitter
Messages : 21
Inscription : sam. mai 14, 2016 6:19 pm
Localisation : Italy

Re: enable-qcas option

Message par sagitter » lun. déc. 18, 2017 11:42 am

frederic han a écrit :Well, it works for me but it was just a quick trick to do the job and I didn't have time to clean or improve things, so it is disabled by default
.

Technically you can switch to dynamic lib:
comment the:

CONFIG+=staticlib
in the unix section and do:

qmake-qt5 libqcas.pro
make

then install the libqcas libs somewhere in the librarypath. (/usr/lib64 looks to work for me), but the current qcas don't use it, it would only be shared by the different giacpy2qcas (python2 and 3) .

quick test in a python console:

Code : Tout sélectionner

import giacpy
A=giacpy.plot('sin(x)')
A.qcas()
Does giacpy use libqcas.so and not libqcas.a? Or it can use both?
mailto: sagitter 'at' fedoraproject 'dot' org
https://fedoraproject.org/wiki/User:Sagitter
GPG Key: 0x5E212EE1D35568BE
Check on https://keys.fedoraproject.org/

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Re: enable-qcas option

Message par frederic han » lun. déc. 18, 2017 1:36 pm

it should be both.
(Usually I use the .a) but I have tried the .so.1 on fc27.x86_64 yesterday because of fedora policy on static libs.
it doesn't work if libqcas.so.1 is in the giacpy dir but it works if it is in /usr/lib64 or anywhere in the LD_LIBRARY_PATH.

But if you have troubles with fedora packaging tools and libqcas, then just keep the default setup.py because I don't have much time to improve this feature.

Répondre