jordan

Bugs

Modérateur : xcasadmin

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

jordan

Message par frederic han » jeu. déc. 13, 2007 8:25 am

Salut,
j'ai des soucis de stabilite avec jordan selon le contexte.
s'il ne peut pas repondre, alors ca plante.
Ex:
A:=companion((x^2-2)^2,x)
il me semble jordan(A) plante si l'on n'active pas les racines carrees, mais fonctionne avec.
En revanche:
A:=companion((x^3-2)^2,x)
alors jordan(A) plante de toute facon, meme avec racines et complexes.

%%%%%%%%%%%%%%%
a part ca, tant que j'y pense:
les matrices avec des fractions ne passent pas bien vers pari:
Ex:
pari_charpoly(A) marche avec
A:=matrix([[2]])
mais pas avec A:=matrix([[2/3]])

a+

Frederic

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » jeu. déc. 13, 2007 11:47 am

en effet, petit bug dans jordan corrige et pareil j'avais oublie la conversion des fractions giac vers les fractions PARI. Ca devrait marcher le temps que je mette xcas_root a jour...

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » jeu. déc. 13, 2007 2:09 pm

super,

merci je testerai

a+

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » sam. déc. 15, 2007 9:17 am

j'ai teste un peu,
Pour les matrice dans pari et pour horner, c'est ok,

en revanche pour jordan, il reste un probleme de plantage avec:
A:=companion(x^3+2,x)
(pour les autres ca marche)

Fred

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » sam. déc. 15, 2007 1:07 pm

c'est a cause du solver, il renvoie 2^(1/3) au lieu de -2^(1/3), je corrige ca lundi, si tu es impatient de tester tu peux faire le patch suivant:
diff solve.cc solve.cc~
376c376
< newv.push_back(delta_x + (negatif?-tmp:tmp));
---
<newv> newv.push_back(delta_x + tmp);
Dernière modification par parisse le sam. déc. 15, 2007 4:23 pm, modifié 1 fois.

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » sam. déc. 15, 2007 2:13 pm

Il n'y a pas d'urgence,

Merci

Fred

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » mer. déc. 19, 2007 1:41 pm

J'ai regarde la version du 18/12
Il reste encore un probleme dans le solve chez moi, car
en mode non complexe ni sqrt alors
solve(x^3+2,x) me donne bien -2^1/3
mais si je coche sqrt et mode complex alors
j'ai encore le probleme de signe 2^1/3,...

a+
Fred

parisse
Messages : 5114
Inscription : mar. déc. 20, 2005 4:02 pm
Contact :

Message par parisse » jeu. déc. 20, 2007 3:43 pm

en effet, ca devrait marcher maintenant (xcas_root).
j'ai corrige un autre bug decouvert par un etudiant ce matin: un grand entier par exemple 20! et un flottant par exemple 2. n'etait pas compares correctement (selon le sens)

frederic han
Messages : 1113
Inscription : dim. mai 20, 2007 7:09 am
Localisation : Paris
Contact :

Message par frederic han » ven. déc. 21, 2007 9:53 am

OK, merci beacoup

Répondre